Troubleshooting: Unable to add Holiday entry to AA Schedule Settings

Issue: 

When configuring a Holiday event for an Auto Attendant, you may receive the Alert below, "the start date of the holiday range must be earlier than the end date".  No matter how many times you verify that this is actually the case, the error persists.

Cause:

While we cannot pinpoint the exact cause of the issue, we've determined that there is some discrepancy between prior holiday events and newer holiday events.

Resolution:

As a one time process, delete all currently defined events under the AA and rebuilt them.  Optionally, if you have company-wide holiday events configured under Company -> Time Schedule, after deleting all events from an AA, you can choose the 'Get Holiday' button in the AA's Schedule Setting -> Holiday tab to import holidays from the company's time schedule first and then alter them as required.